Camera turn speed crazy fast with controllers on PC

I really want to play this game! My issue is that the camera turn speed on controllers is INSANELY FAST. I can’t turn it down and I can’t play the game like this.

Does anyone have any suggestions about this? If I have to, I’ll play on keyboard/mouse but I much prefer to play games (even if on PC) on controller.

Thanks for any tips!

Do you have Steam running in the background also? If so, completely quit out of Steam.

I’m on Playstation so don’t have that issue, but when I downloaded the patch, the settings menu allows you to adjust the camera sensitivity.

1 Like

I’ll quit Steam and see if that helps - there doesn’t seem to be a setting to change camera sensitivity. When was the patch?

I think it was the 30th June.

1 Like

Okay the camera speed issue is fixed! Now, can I disable 30 fps mode in cutscenes? I’d rather have it 60 fps+ all the time. It’s jarring to keep changing.