Game won't launch on Epic Games

Bought the game through Epic Games but refunded it cause the game wouldn’t launch.
Only says “running” and the only thing I can do is close the game through Task Manager.
Had this issue once before on Epic with a game and only on Epic, so never on Gog or Steam, and they weren’t able to solve it.

Already sent a message to support over here hoping that they have an idea what might be going on.
If it can be solved I would surely buy the game again cause I was really looking forward to this one.

In case any of the other gamers have an idea how to solve it and have experience with a similar issue through Epic, feel free to leave a post.

Thank you in advance :smiley:

Hey @Previous_Complex I had a similar issue where it was a little choosey on if it would load or not, I just uninstalled and reinstalled and that solved it. Not very technical (Similar to “Turn it off and on again!”) but worked for me! :vulcan_salute:

Thx for your reply buddy :smiley:

Was this on Epic Games and with this game?

With another game on Epic it didn’t work at all even after uninstalling and reinstalling.
Other games I own on there work just fine.

Yeah I was on Epic for this.

I’ve had issues with Epic in the past and it seems to “Work itself out” so it could be a platform issue rather than the game itself. So might be worth raising it with Epic too perhaps?

Like I’ve mentioned in my first post Epic never found a solution for that other game, even after weeks, hence why this time I didn’t even bother to contact them cause its exactly the same problem.

Waiting for a reply from support on here and hope that they can find a solution :crossed_fingers:

Thx for your time though :smiley: :v:

You did! sorry I missed that!

You can also try reporting it here on the support page. There is a form right at the bottom, might get you through to the right people quicker!

I know, already submitted a ticket :wink: