Crashes on Asus ROG Ally

I’d started playing Star Trek: Resurgence on a Steam Deck via Heroic Launcher (which lets you run Epic Games Store stuff) and it worked well when logged on to Wi-Fi, but had issues due to Heroic not liking being offline when trying to play on a plane.

So got my new Asus ROG Ally handheld and was excited to play with no hacks, since it runs Win 11/EGS.

And though I can get to the game’s menu, when I load or start a game, it crashes to the desktop, and though I can’t see the window there’s an “Unreal Engine 4 Crash Reporter” task left running. Looks like it might be the same issue encountered here.

Really frustrating since this was the game I was most looking forward to playing!


Okay so its not just me. I just got my Ally yesterday and was excited to play this. I held off on console because I wanted to be able to play Resurgence on the go but I can never get past the save slot selector without U4 crashing.

Yep, not just you. The Reddit r/startrekresurgence discussion confirms it doesn’t work for any of us:

And on the r/RogAlly subreddit as well:

Hopefully the dev team is aware. No idea if they read this forum or if the mods pass on bug reports.

Same, also crashes on Steam Deck. Resurgence is the only game out of over 100 I’ve tried that does this, and the patch doesn’t help. I suspect it’s an issue with AMD APUs. I really want to recommend this game to more people (played on an Nvidia machine), but i just can’t do so in good conscience when it’s in this state. It’s kind of amazing to me that this hasn’t been fixed, it’s not like AMD hardware is a tiny niche category. But i guess these days if you’re not a Playstation or an Xbox, you’re an afterthought.